Wikia

Memory Alpha

Memory Alpha:Ten Forward/MediaWiki 1.5 Comments

Discuss0
37,512pages on
this wiki

< Memory Alpha:Ten Forward

MediaWiki 1.5 Comments Edit

Discussion Edit

OK, so we were upgraded to MediaWiki 1.5. I wanted to make a few comments, and I thought this to be the best place. Not that this will probably change anything, but I wanted to talk about it.

  1. Broken links are a darker shade of red. Don't like it.
  2. The search is has the Wikicities logo on it. I know it's not really any different, but I like the old one without a logo better.
  3. The Google search has got to go. What's the point? Also, it looks bad with the dark background.
  4. The red exclamation points on the recent changes page. What's up with that? Nevermind, they're gone now.
  5. A few technical problems, like an odd looking list on (at least my) watchlist and an "[undefined]" link at the bottom of some TOCs, like the one on this page (but technical problems are to be expected an will be fixed).
  6. The dealy on the top of image pages. Is that really needed?
  7. It wont let me keep the space at the beginning of my signature like it used to. Now I have to manually put a space between my text and the ~~~~. (Added 13:12, 18 January 2006 (UTC))

Now you know what I think. Comments? -Platypus Man | Talk 05:07, 18 January 2006 (UTC)

The darker shade for the links don't bother me. And I think the Google search engine is a great, handy thing to have; it makes it easier to search for Trek-related items and possible copyvios without opening another page. However, the outline for the Google logo could be done better.
The red exclamation points are still on the rc page, and are very distracting, although I guess we can live with that.
As for the Wikicities logo, it should either be replaced with an MA logo or removed altogether.
There are several technical problems still to be worked out, specifically with links in the MediaWiki templates. Also, the white background on the Yahoo! ad bar to the right needs to return to its original black color.
And that's all I gotta say 'bout that. --From Andoria with Love 05:45, 18 January 2006 (UTC)
I have different things to address: on my laptop the google ads on the right side are overlapping the text. In the TOCs the header is big and yellow, undefined was already mentioned above. The red exclamation marks are white for me, so I think it is a css thing. Yesterday in fr the navigation was missing, though it seems fixed now. -- Kobi - (Talk) 08:14, 18 January 2006 (UTC)

Regarding those ads, I had to switch to IE to see them because I've had them blocked on Firefox for longer than I've been here. I agree that they would/did look better with a black background. Of course, the best solution is to not see them...-Platypus Man | Talk 13:12, 18 January 2006 (UTC)

I will try to look into some of the CSS issues later today - please still post them and others as you find them. There seems to be an issue with HTML code in messages in the Mediawiki: namespace, for example. No idea if this is a temporary issue or if we'll have to find ways to use Wikicode only there. The Google search can be useful from time to time, because the internal search sometimes doesn't find what you want it to find. The image used at the moment is ugly, though, that's correct. -- Cid Highwind 14:30, 18 January 2006 (UTC)
Anyone experiencing the "Ads overlapping the right side of the page" bug should hit "ctrl-F5" (or however you force a refresh on your particular browser or OS) to purge the old style from your cache, the ads load fine after this. -- Captain Mike K. Barteltalk 14:40, 18 January 2006 (UTC)
Thanks Mike, you saved my computer from an atroce murder (by me). Since the upgrade, I took twice the time to look and edit the pages with this Google overlapping. There is still a problem with images : there are now headers (Image, historic, link) before the image, then there are technical infos about the image ["Ten_Forward_(bar).jpg (43Ko, type MIME: image/jpeg)"] just before the legend, which make image article completely stupid. It is possible that it only occurs with the french preferences of navigation. - Philoust123 14:59, 18 January 2006 (UTC)
I've noticed that the image legend "dealy" has a wikimedia/wikicities style artifact giving it a light background (a lot of "light background" areas have been showing up, these could be corrected on some of our style setting so they look less intrusive). If a consensus exists, possibly alter the color format for some of the other changes (like the darker red links). If these changes are truly possible, i'd suggest not only darkening the light backgrounds, but somehow centering or de-accentuating the MIME type data so it can be more easily discerned from the image description. -- Captain Mike K. Barteltalk 15:14, 18 January 2006 (UTC)
The Google logo currently being used is http://www.google.com/logos/Logo_25wht.gif [1], which is dithered for a white (or light) background. Try replacing it with http://www.google.com/logos/Logo_25blk.gif [2], which is dithered for a black (or dark) background. -- Renegade54 15:49, 18 January 2006 (UTC)
The black background for the Google logo looks a lot better. Can somebody make the changes? Also, to Mike, I support any changes which make the site look better, although I am indiferent to the brightness of the links (at the moment, anyway :P). --From Andoria with Love 16:06, 18 January 2006 (UTC)
Has anybody noticed that instead of an arrow we now have "&larr" when reviewing an article's changes? :P --137.155.51.176 16:11, 18 January 2006 (UTC)
That's because "&larr" is the HTML code to insert the symbol "→". The new version of the software doesn't support such HTML tags, so any like these would have to be fixed.
 :P indeed -- there's no need to stick out your tongue -- although i feel like doing that whenever i have to remind people not to use HTML tags on MA ;). -- Captain Mike K. Barteltalk 16:29, 18 January 2006 (UTC)
I guess I'm a bit confused... HTML tags seem to work just fine on the pages. For example, here are the tags for the left and right arrows: ← → They seem to work just fine, as do all the other tags on all the pages. So... why aren't the ones in the MediaWiki space working? (And why are we not supposed to use them here?) -- Renegade54 16:51, 18 January 2006 (UTC)
Yes, they work fine -- on some pages, such as the main article space. They do not work across certain types of code variations (for example the site coding contained in the MediaWiki namespace -- they don't work there because those codes are being saved on one page, but displayed by the wiki code on special pages). They probably don't work well when a normal article page is processed or queried by our special pages or search features -- which is exactly why our policy states that in all cases, HTML should not be used when there is a wiki code or another way to insert a character, table or etc., it should be used. -- Captain Mike K. Barteltalk 17:15, 18 January 2006 (UTC)
Regarding the diffs issue, there are pages Mediawiki:Previousdiff and Mediawiki:Nextdiff, but the wording used there is different from the one used on diffs. Maybe what we see there is hardcoded somewhere, where the content of those Mediawiki: pages should be used instead? -- Cid Highwind 17:16, 18 January 2006 (UTC)
I didn't change anything yet, but had the chance to ask Jason on the wikicities chat about the problem I mentioned above. The "diff" issue seems to be fixed now, so whatever the problem was with the existing Mediawiki: pages not actually being used, it seems to be fixed now. Please check again all pages you had HTML issues with and remove/add them from/to the list below. Thanks. -- Cid Highwind 16:18, 19 January 2006 (UTC)
TOC heading issue. I don't see that here, and already left a note on Kobi's talk page. Does anyone else that? If so, please post here so that I can see if it might have something to do with custom CSS files. -- Cid Highwind 16:28, 19 January 2006 (UTC)
Custom signature issue. I don't know about that, but it might be some sort of new feature instead of a bug. Workaround: Try to start your custom signature with something else; for example, add the double dash typically used to your signature. -- Cid Highwind 16:28, 19 January 2006 (UTC)
Google image. I removed the image temporarily, but in the long run, something else has to be done. I already asked about the possibilities to change these boxes somehow. -- Cid Highwind 23:49, 19 January 2006 (UTC)

I don't think the custom signature thing should be an issue really - I can see where it would remove an extra space at the beginning, kind of like leading zeros in a number. Just put the space in. :)

As for Google, Shran was right about it being useful, but 90% of us probably have that box already, whether it's the search box for modern browsers or Google Toolbar for IE. Either way, having that box is really about Wikicities getting money from ads you click when your search originates there.

For some reason the "Search This Wiki" picture is there but not, like I get a box with the text, like it's downloading the image but never gets there. Once we get past all these other issues, we should discuss some cosmetic changes, because I don't know if it's the upgrade or I'm just noticing, but the dark blue color for visited links is really hard on the eyes with our current background (that's probably a discussion for the "layout committee" page though). --Vedek Dukat Talk | Duty Roster 21:22, 20 January 2006 (UTC)

Isn't the dark blue the same as before? I think only the red for dead links changed and is darker now (what I don't like too). Concerning the WC and Google logos: just remove them, they waste space at the left side. Replace them with a small sized font saying "Internal search" and "Google search". --Memory 21:40, 20 January 2006 (UTC)
Yes, the first picture is still missing. Problem with the original image was the fact that it was not located somewhere where we could simply upload another one. I made the Wikicities guys aware of that, and the image apparently was removed from there, although the sidebar code still points to it. I guess this is one of the minor issues currently on their list, and will get fixed soon.
Regarding the link color, both should be exactly as before, but I'll look into that again. I guess that really is a case of "just noticing", because dark blue on dark grey always looked a little suspicious to me... ;) I'm also not a big fan of glaring red on dark grey, so we definitely should add link color to our list. -- Cid Highwind 21:49, 20 January 2006 (UTC)
Red link color. You were right, I was wrong... I checked the exact color of our redlinks, and it was one not defined in any of the standard CSS files. Apparently, there's another file since the update that contains nothing but the definition of a slightly darker red for those links: see here. I don't have any idea why this might be useful in any way... but it's there (for the moment). -- Cid Highwind 22:36, 20 January 2006 (UTC)
Addition: It's there because one of the developers decided it would be a good idea to use hardcoded color values in one of the program files running this site. This is a known bug, so maybe it'll get fixed some day. Meanwhile, the only possibility to get rid of that color is to create a user stylesheet "User:YOUR-USERNAME/monobook.css" and add to that page the following:
/* Fix for generated user stylesheet */
a.new, #quickbar a.new { color: #BA0000; }
This will override any color settings in the sitewide stylesheets. -- Cid Highwind 11:48, 21 January 2006 (UTC)
Search images: Still an ugly hack (perhaps even more than the first one), but now we at least have images that actually work until someone comes up with a better solution... ;) -- Cid Highwind 22:37, 23 January 2006 (UTC)

List of design issuesEdit

Note: Please continue the discussion above, but feel free to list each issue here as well. I (or perhaps, someone else who wants to) will strike out each issue as it is fixed. -- Cid Highwind 16:44, 18 January 2006 (UTC)

  1. Color of exclamation marks.
  2. light background on image legend (please specify); related: suggestion to center legend
  3. Ad bar overlapping content (still happens here after forced reload) A problem with my custom css, apparently.
  4. the unresolved New Pages page is hard to read issue (probably old news, but still an issue) Shanok 18:32, 18 January 2006 (UTC) Fixed again, css class was renamed.
  5. "Odd looking" watchlist (please replace this with a more specific description) I assume this referred to the broken message on top, because it looks normal to me. If it refers to something else, please add it again with a more specific description.
  6. "undefined" after TOC Whatever that was, it no longer exists.
  7. size of table header and numeration: image (though in german, it is the same here) -- Kobi - (Talk) 17:37, 18 January 2006 (UTC)
  8. Broken links are a darker shade of red.Checked and updated CSS, should be fixed. Let me know if not.
  9. Wikicities and Google logos. Remove or replace. See also File talk:Search_logo.png
  10. *I've replaced the Google logo by the black background one as suggested above. If you remove the CSS hack you'll see it. What do you want me to do about the Wikicities logo? -- Tim Starling 01:37, 24 January 2006 (UTC)
  11. :*For the Wikicities logo, I say we remove it completely like it was before the upgrade or change it to a specific Memory Alpha logo, but I would prefer the first one. -Platypus Man | Talk 20:41, 24 January 2006 (UTC)
  12. Ad bar background color.
  13. the space before a custom signature will not stay permanent as it did before. -Platypus Man | Talk 20:35, 18 January 2006 (UTC)
    • Cid Highwind already suggested that, but it didn't work then. For some reason, it does now, though. Thanks! -Platypus Man | Talk 20:41, 24 January 2006 (UTC)
  14. Change the other languages version of MA after all new designs have been approved - Philoust123 16:07, 20 January 2006 (UTC)
  15. Visitor count at page bottom -- Rcog 16:05, 24 January 2006 (UTC)

HTML codeEdit

Note:List pages that show HTML code here, so that the appropriate templates and Mediawiki: pages can get fixed

  1. The Searching and matching page (the MediaWiki page for this can be found here; one of the codes was fixed, but there may be a better way for that)
  2. The protected page warning (this can be found here; I have corrected this for the time being, but there may be a better way to fix it)
  3. The arrows for going to previous and next pages when searching through an article's changes (I have no bloody idea where the page for this is). --From Andoria with Love 17:02, 18 January 2006 (UTC)
  4. The Watchlist. -Platypus Man | Talk 20:37, 18 January 2006 (UTC)
  5. [[:Memory_Alpha:Short_articles]] - Intricated 18:29, 28 February 2006 (UTC)
Apparently the page above is obsolete (re: Special:Shortpages). Forget the formatting. - Intricated 18:34, 28 February 2006 (UTC)

Blue DotsEdit

Does anyone else notice that the blue dots next to external links often cover parts of the text? Admin/Wikicities people, is it possible to fix this? Jaz 06:19, 21 January 2006 (UTC)

Do you mean the "pointing out" arrow? That never happened to me. Is this a new bug / can you provide a screenshot / which browser/version are you using? -- Cid Highwind 11:51, 21 January 2006 (UTC)
I think Jaz is speaking of the globes in external links: instead of appearing after the text, they are now right-aligned to the text and appear above the text. [3] -- Kobi - (Talk) 12:01, 21 January 2006 (UTC)
Strange, I don't even see these icons... Anyway, a "padding" instruction seemed to be missing, which I now included. Can you check if that solved the problem? -- Cid Highwind 12:11, 21 January 2006 (UTC)
Cid, I'm using Mozilla Firefox, becuase IE gave me about a hundred times more bugs (pages load w/ errors, or not at all). Jaz
As much as I enjoy using Firefox, I think we should resolve such issues instead of just switching browsers. Not that I'm complaining, but seeing how the majority of Internet users still do use IE, we should figure out what's wrong and fix it to avoid giving a bad impression. --Vedek Dukat Talk | Duty Roster 06:21, 22 January 2006 (UTC)
Is it intentionally that the Wikipedia and interwiki links have blue dots now? -- Kobi - (Talk) 13:34, 22 January 2006 (UTC)
In the CSS file, this bluedot/globe thingy is used to mark all links that contain an URL starting with either http or gopher - which basically translates to "external link", because internal links use a relative URL instead. Apparently, Opera doesn't interpret these instructions correctly, so I'm personally not seeing any icons (there are also supposed to be icons for https, mailto, ftp and others). What do you guys say, should these icons be removed completely, changed to something else, or what? -- Cid Highwind 18:18, 22 January 2006 (UTC)

Around Wikia's network

Random Wiki