Wikia

Memory Alpha

Memory Alpha now at Mediawiki 1.19 -- Report issues here

37,159pages on
this wiki

Forum page

Revision as of 11:05, October 31, 2012 by Aatrek (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Forum icon   ForumsTen Forward → Memory Alpha now at Mediawiki 1.19 -- Report issues here (replywatch)

Last night, Memory Alpha was upgraded to MediaWiki 1.19 and a number of bugs and other issues have arisen. Please report them in this thread so that I can ensure that they are being taken care of by Wikia staff.


Page moves by Admins (reported)Edit

Pages cannot (always) be moved overtop of already existing pages and inform the user that only an admin can do it. This even happens to admins sometimes. -- sulfur (talk) 17:04, June 26, 2012 (UTC)

CSS Issues Edit

Monobook formatting is screwedEdit

Are you seeing weird stuff with Monobook like I am? Did Wikia do an upgrade or make some change? -- Renegade54 (talk) 13:34, June 26, 2012 (UTC)

I'm seeing a white background in the main article space instead of the usual. It was fine when I edited earlier today so whatever happened, happened since then. 31dot (talk) 13:51, June 26, 2012 (UTC)

Yeah, that's what I'm seeing too. And for whatever reason, ads aren't getting blocked any more (using AdBlock+ with FF 13.0.1). I'm seeing the same with IE8 and Opera 12 as well. -- Renegade54 (talk) 13:57, June 26, 2012 (UTC)

For what it's worth, I too see the screwed up formatting. --| TrekFan Open a channel 14:20, June 26, 2012 (UTC)
For me, I use the awful Wikia skin (so that I can see what anons and general visitors see), and the entire footer is utterly pooched at the moment. As such, I would suspect that the CSS has been botched badly on that front. I would also think that the ads may have changed URLs to avoid the AdBlock+ protection. -- sulfur (talk) 14:25, June 26, 2012 (UTC)
I noticed that when I start to type an internal link, the autosuggest comes up underneath the edit box, and not within a popup box near where I typed. I never noticed that before. 31dot (talk) 15:31, June 26, 2012 (UTC)
They are working on an "upgrade" to the Wiki software; don't know if that's relevant. 31dot (talk) 16:44, June 26, 2012 (UTC)
Is there a chance we get the Monobook back as it was? Everything in the background is white for me, too. And it is really strange editing right now. Tom (talk) 18:57, June 26, 2012 (UTC)
Oh great, can't leave it alone can they? Yep, my page backgrounds are white too, and most text now defaults to black which makes things like infoboxes and the main page really hard to read. StalwartUK (talk) 08:20, June 27, 2012 (UTC)
so half the front page is in white and you cant see the links unless you use your mouse to highlight over them. Text is in black over most of the front page and on a black background. All the article pages have a white background (like wikipedia). I dont know if that is what they meant with "reporting" it here, but yeah here it is. Distantlycharmed (talk) 22:18, June 27, 2012 (UTC)
CSS issue, so moving it to that section of the page. -- sulfur (talk) 10:23, June 28, 2012 (UTC)
I'm seeing none of this, beyond what's below. Can you get a screenshot? - Archduk3 18:43, June 28, 2012 (UTC)
Tom paris article screenshot

screenshot

Screenshot MA main portal

screenshot

Here is the mess.
I totally forgot how to upload pics and add licence. And it takes minutes for a page to load. Distantlycharmed (talk) 21:00, June 28, 2012 (UTC)
That's a monobook issue, so I've moved it to that section. It looks like the CSS class name for the background was changed. - Archduk3 21:26, June 28, 2012 (UTC)
Tbis has improved somewhat (I think due to Renegade54); I am now only seeing white around the article space and including the title of the page. 31dot (talk) 22:42, July 2, 2012 (UTC)

Yeah, I mucked around a bit with the CSS to get the formatting right for article text. I haven't figured out yet what part of the page the border belongs to. I'm open to suggestions, if anyone has any... otherwise, I'll just keep looking. :) -- Renegade54 (talk) 15:11, July 3, 2012 (UTC)

I didn't say it above, but thanks. :) 31dot (talk) 15:16, July 3, 2012 (UTC)

OK, for the life of me I can't figure out why the padding isn't picking up the background color. It used to do that, it's *supposed* to do that (according to everything I've read)... so why isn't it? That's why there are white borders around stuff. I'm certainly no expert on CSS, so I'd be happy for any guidance on this. -- Renegade54 (talk) 14:16, July 5, 2012 (UTC)

I am now only seeing white on the left side of the article space in between the article and the nav bar. 31dot (talk) 20:32, July 5, 2012 (UTC)
Let me amend that slightly and say that I see white around the sides and on the bottom of the article space, but not the top. 31dot (talk) 20:37, July 5, 2012 (UTC)

Yeah, I tracked down one more. The underlying problem is that with the MediaWiki upgrade, we also changed from the HTML 4 to the HTML 5 standard. One of the things that's deprecated in HTML 5 is support for the background color in the body object; it now needs to be specified everywhere it's used. I just haven't figured out where everywhere is yet. :) -- Renegade54 (talk) 20:49, July 5, 2012 (UTC)

Hi, MediaWiki in the german Memory Alpha has recently been changed by Wikia. Now we have a similar problem as described above. It seems as if the problem has already been solved her, but it seems that nobody has written down a solution. May i ask how you solved the backgound issue? what do i have to change in the css document? --D47h0r

Image categories and file description page - CSS Edit

The gallery for the image categories and the file history box on the file descriptions pages have color issues. Is this due to a change in the CSS name for these, as in something we should change, or something that will be fixed on wikia's end? - Archduk3 18:44, June 26, 2012 (UTC)

Also, there is a white highlight now on images. - Archduk3 18:47, June 26, 2012 (UTC)

I suspect that we'll have to change this due to our colour customizations.
And what do you mean by "white highlight"? -- sulfur (talk) 20:15, June 26, 2012 (UTC)

Images with a transparent background, or at least some of the rating logos, have the background go white when the mouse is placed over it. This should be changed to #222, as we don't use white like that.

Do you know what the old CSS classes were for these, so the new ones can be added? - Archduk3 08:52, June 27, 2012 (UTC)

There were no old CSS classes, but the new ones appear to be in this sequence. I just can't figure out a few things now, because my personal wikia.css no longer seems to be loading with MW1.19. Regardless:
.filehistory img:hover {
background: white url(images/Checker-16x16.png) repeat;
}
That's the CSS loading and flipping the BG to white, but I can't see how to fix that offhand. -- sulfur (talk) 18:34, June 27, 2012 (UTC)

Looks like we have to wait for the CSS loading problem to be fixed first then, unless someone wants to try it from central. - Archduk3 20:19, June 27, 2012 (UTC)

Text Skewing Edit

On certain pages (and I'm not sure how many), portions of text are off to the side, in a vertical column. Also, on some pages (specifically "Beta Quadrant", the bar with the phrase "Covers information from several alternate timelines" is split into two sections, with the page title in between. I've noticed these bugs only on the pages regarding the Alpha, Beta, Gamma, and Delta Quadrants--although it may not be limited to just those four. It's very disconcerting. If there's anything that can be done about it, please at least consider it, and thanks in advance.

75.66.85.99 00:40, June 27, 2012 (UTC)

Can you get a screenshot and post it? -- sulfur (talk) 02:31, June 27, 2012 (UTC)
Aside -- it's the articletype headers that are shot right now. -- sulfur (talk) 02:33, June 27, 2012 (UTC)

Personal CSS not loading (reported) Edit

With MW1.19, personal CSS files are not loading from local wikis, and only appear to be loading from community. -- sulfur (talk) 18:50, June 27, 2012 (UTC)

Text-align Edit

Text-align may not be working right, see the POTD on the main page. - Archduk3 18:43, June 28, 2012 (UTC)

It seems that this is about the upgrade to HTML5, so I'm not sure how much of what we have is going to be effected by this. I made some changes to the things I know were broken, but please report anything else here or just make the changes as outlined at central. - Archduk3 18:29, July 6, 2012 (UTC)

Weird stuff on the 'Recent Changes' page Edit

Recent changes layout error

Anybody else getting a weird overlay on the Recent Changes page? - Aatrek 00:23, August 9, 2012 (UTC)

Yeah, I'm getting that as well under the "New Wikia Look". It's fine in Monobook though.–Cleanse ( talk | contribs ) 01:00, August 9, 2012 (UTC)
This needs to be fixed. - Archduk3 20:59, August 11, 2012 (UTC)
Well, removing the JS that corrects the location of the "show changes since" link fixes the problem with the drop down menu, but reintroduces the original issue. I'll ask around to see if anyone knows how to keep the link where it is in the order, not to mention somewhere usable that isn't occasionally directly on top of other text, without breaking stupid crap that wikia introduces. - Archduk3 20:51, August 12, 2012 (UTC)
Fixed. - Archduk3 04:51, August 23, 2012 (UTC)

Sortable tables acting weird Edit

Ca someone else check NCC to see if I'm the only one seeing the sortable tables without the gradient. The column "heads" are also larger than they should be. Using the most current version of Firefox in case it's that. - Archduk3 01:29, August 15, 2012 (UTC)

I'm seeing the same thing in Chrome.–Cleanse ( talk | contribs ) 07:18, August 15, 2012 (UTC)

Dark text in Monobook Edit

On Monobook the text on the file history part of the image pages is black, same as the background.

On a related issue, I've noticed that on the Oasis/Wikia skin the color of the byte change text on pages such as "My Contributions" is much brighter than it is on Monobook. StalwartUK (talk) 02:30, September 20, 2012 (UTC)

If you're talking about the green and red colors, that might be because the class name changed in monobook (or some similar CSS problem) because they are were all suppose to be the brighter colors to help them stand out, or I'm simply remembering it wrong and the monobook colors weren't changed when the other ones were. If it helps, I think this was done when we we're having problems with the diffs for the page histories. - Archduk3 15:11, September 20, 2012 (UTC)

Createbox broken for Forums (reported)Edit

Right now if you create a new forum entry, the namespace is doubled so that you end up with "Forum:Forum:" at the start of the article name. This is a known bug and documented here -- sulfur (talk) 17:19, June 26, 2012 (UTC)

You got any more details on this, sulfur? There's been a but with inputbox for ages, but you guys aren't using inputbox, are you? You're using createbox, right? I thought createbox was the more stable version of inputbox. We've never detected this error over at w:c:tardis throughout this whole 1.19/HTML 5 transition, so I'm curious how you have. I've looked at your code for forum thread creation, and it looks like it's createbox all the way. And I can't recreate the error. Have you fixed this issue in the intervening days since posting?
czechout@Wikia    02:32: Sun 12 Aug 2012 

It seems that this may have been fixed somewhere along the way with my ticket never being updated by Wikia. -- sulfur (talk) 02:39, August 12, 2012 (UTC)

GlobalUsage not properly configured (reported)Edit

Special:GlobalUsage is now installed (as per our request), but not properly configured as yet. (see this forum for further discussion) -- sulfur (talk) 17:30, June 26, 2012 (UTC)

Slow JS Edit

Anyone else notice that pages that use JavaScript are loading slower. If it's just me, let me know, but the recent changes is like getting molasses from a long necked bottle. - Archduk3 08:58, June 27, 2012 (UTC)

No, it's not just you. I'm seeing it too... I thought it was just me! heh -- Renegade54 15:20, June 27, 2012 (UTC)

Edit conflicts Edit

Neither of the boxes shows "your edit", both of them have the text of the edit conflict, making it quite useless. - Archduk3 16:59, June 29, 2012 (UTC)

Next it happens, can you screenshot it? -- sulfur (talk) 17:03, June 29, 2012 (UTC)

Redirects Edit

If you use a redirect and then try to edit the page, you will be editing the redirect. Good times. - Archduk3 22:40, June 29, 2012 (UTC)

Likewise, if you use a redirect, the "Discuss" link will be to the redirect's talk page.--Cleanse ( talk | contribs ) 22:03, July 1, 2012 (UTC)
Furthermore, History, Move, Delete and Protect will all relate to the redirect, but "What Links Here" will give info on the actual page. Go figure.--Cleanse ( talk | contribs ) 23:29, July 1, 2012 (UTC)

Delete and move Edit

If moving a page requires a deletion of the destination, the move no longer happens and the deletion "takes priority"; you are redirect to the main page with the "undelete" message. - Archduk3 09:30, June 30, 2012 (UTC)

Image LightboxingEdit

It's back. We need to find a workaround for the annoyance that it is. -- sulfur (talk) 19:27, July 11, 2012 (UTC)

Dear god, yes please. I've got my new TNG Blu-Ray set to start capping, and that pop-up is killing me. I miss my middle-click functionality! - Aatrek (talk) 19:59, July 24, 2012 (UTC)
I would still like to have the option of using this for the IotD on the main page, but having this on site wide is a borderline copyright violation since you can't easily get to the file page for images in galleries and sidebars. The added "features" of it also cause it to load much slower than the old one. - Archduk3 21:58, July 24, 2012 (UTC)

There is a fix for this now, but it's a JS fix rather than a CSS fix (which is what the original was). See here. -- sulfur (talk) 13:12, August 13, 2012 (UTC)

"Null" on preview (reported) Edit

In certain circumstances in Oasis previews, an annoying, but basically harmless, word "null" will appear in the bottom left hand corner of the preview lightbox. Apparently the conditions have to do with a lack of categories. Because most sections have no categories in them, previewing a section of a page will produce this phantom "null".

Wikia have been alerted, and they say a fix is coming as early as next week.
czechout@Wikia    02:35: Sun 12 Aug 2012 

Catlinks not wrapping (reported) Edit

As can be seen at Spock and other pages that are heavily categorised, #catlinks is no longer text wrapping. Or perhaps, more precisely, it's treating each category name as one unified block of text that can't be broken. Anyone got a clue what's going on with that or how to solve it? I started a thread at community:Admin Forum:Categories not wrapping after MW 1.19 update, but no one has yet taken the bait.
czechout@Wikia    02:44: Sun 12 Aug 2012 

Just wanted to keep you guys apprised so you don't have to go to w:c:community. This issue has been tagged as a bug by Wikia staff. The default behaviour is therefore expected to change. In the meantime, there's a workaround that you can drop into your Common.css:
.mw-normal-catlinks li { display: inline;}
Hope that's helpful.
czechout@Wikia    19:12: Mon 13 Aug 2012 

Better email notifications for moves Edit

I don't know if this is the correct section for this or not, but: is there any way for email notifications to include more information on image/page moves? Let's say there was a page called File:Picard's birthday.jpg - if this was moved to File:Picard's 50th birthday.jpg, the email notification says "It's been moved!" and includes a link to the old file - but not a link to the NEW file location. That means you have to figure out where it was moved to manually, instead of the site just telling you. Is there any way to make this adjustment? - Aatrek 22:57, August 31, 2012 (UTC)

I would recommend sending this suggestion to Special:Contact. -- sulfur (talk) 23:48, August 31, 2012 (UTC)

Temporary editing issue Edit

Did anyone else notice editing temporarily go down across Wikia? Is this relevant to the formatting thing? SPQR (talk) 22:24, September 4, 2012 (UTC)

DB related. It happens more often than we'd like. :( -- sulfur (talk) 23:36, September 4, 2012 (UTC)

Facebook Login Edit

I can't log in through Facebook. Manganzona (talk) 18:33, September 8, 2012 (UTC)

Publications Listing. Edit

I noticed that since May, the publications list hasn't been updated. Don't know if that's related or not.The preceding unsigned comment was added by 70.68.51.73 (talk).

Probably not; it most likely just hasn't been updated. 31dot (talk) 10:32, September 18, 2012 (UTC)

Main drop down menu goes grey when i hovered over it and I couldn't select anything.

Search Edit

Memory Alpha has some behavior I find annoying that is different from all other Wikis I have seen. Like other Wikis, there is a single search box on the front page for finding articles. Unlike other Wikis, it always does a full-text search and takes me to a page of search results, typically with my desired article at the top of the list. On every other Wiki I use, if I type the title of an article exactly or differing only in the use of upper and lower case, I go straight to the article. Memory Alpha's intermediate page of search results means a few extra seconds and one extra click to get to the desired article. It's not a huge deal, but it's annoying. Why is Memory Alpha set up that way? 24.251.127.109 21:33, October 20, 2012 (UTC)

I have the same behaviour on MA as other Wikia wikis with the search box. Perhaps it's something that anonymous users encounter as opposed to logged in users? -- sulfur (talk) 00:00, October 21, 2012 (UTC)

Around Wikia's network

Random Wiki